Macbook will not do anything apple related?

I went through a system restore yesterday and got the attached error when attempting in install Mojave via system restore. I ended up completing the restore, but it installed Yosemite (10.10) instead of Mojave. When I got into the computer and tried to update to Mojave via the app store, I get the same error message. In addition, when I click "Updates" in the app store, it throws an error -1012 and says that it can't find any updates. I am also trying to install Windows 10 via bootcamp. I have the ISO file, but when bootcamp attempts to "download windows support files", the creation fails due to a "network error". This all started at about 3PM CST yesterday. To date, I have attempted a router and modem restart, several computer restarts, PRAM reset, DNS cache clear, renew DHCP lease, another OS reinstall, attempted to update to 10.11 (not available for your system error), spoken to 6 different apple support agents, and I'm getting nowhere fast. Please advise I have also attempted to use a proxy server Also, prior to the system restore, the computer was on Mojave.


error creating usb