Why did my Keurig 2.0 stop whooshing?

I've had my Keurig 2.0 for a couple years now, it's been working great until recently. What is happening is the part of the brewing cycle that extracts the last of the water from the pod stopped working (the whooshing to which I'm referring. The water output amount is fine, the rest of the brewing process works properly, it's just that the pods end up full of water. I've removed and carefully cleaned the pod holder and the undertray diffuser, and used the cleaning device on the top needle as well. I'm guessing there's some secondary pump that's not working? Whaddayathink? Thanks for reading!


I can't think of anything except that the water evaporates and finishes its water transfer cycle before all the water has a chance to go out of the coffee maker. This is most likely due to a faulty water evaporation and transfer process due to using the machine a lot. It sounds like the machine needs to be repaired. It would probably be cheaper, though, to get a new one. You can get new ones at Target for like $60.00 probably. Hope this helped. Max


Fixed it ~ did a couple of things. First I unplugged it, let it cool down then turned it upside down over the sink and gave it a couple love taps to dislodge any gunk (a tip I picked up from housewifehowtos.com), nothing came out but it may have shifted some stuff around. Then I ran a safety pin through the orifice in the top needle. Ran an 8 oz. hot water cycle and got some gurgle at end-of-cycle, then tried a coffee pod 12 oz cycle, and it worked as normal. The water was fully extracted from the pod, the output volume was spot-on and the coffee was just right. Yay me!


Just buy a brand new Keurig